Compatible Web Browsers

If you’re using an out-of-date browser to access BeFunky, you will most likely see an error message prompting you to update your browser. Out-of-date browsers have a lot of security vulnerabilities that make your computer unsafe while using the internet. Also, BeFunky will not function correctly when using an out-of-date browser. Below you will find a list of our minimum requirements for what browsers we currently support: 

  1. Google Chrome - 55 or later
  2. Firefox - 48 or later
  3. Safari - 11 or later
  4. Microsoft Edge - 15 or later
  5. Opera - 40 or later

If you’re unsure as to what browser you are currently using, go here:

https://www.whatsmybrowser.org/

If you find you’re using an unsupported browser, we encourage you to update your browser (if possible) or download a new browser. For the best experience with BeFunky, we recommend you download the latest version of either Google Chrome or Firefox.

Below, you’ll find information about how to update your browser and/or download your new browser

  1. Google Chrome
  2. Firefox
  3. Safari
  4. Microsoft Edge
  5. Opera

And of course, feel free to contact us with any questions you may have.

2 out of 2 found this helpful